OVHCloud Web Hosting Status

Current status
Legend
  • Operational
  • Degraded performance
  • Partial Outage
  • Major Outage
  • Under maintenance
FS#13243 — xc35.mail.ovh.net
Incident Report for Web Cloud
Resolved
There's currently an issue with mailbox access.

Update(s):

Date: 2015-05-05 07:38:28 UTC
mailbox access are back. There was an unusual slow down from backup system. We are investigating.
Posted May 04, 2015 - 14:10 UTC