OVHcloud Web Hosting Status

Current status
Legend
  • Operational
  • Degraded performance
  • Partial Outage
  • Major Outage
  • Under maintenance
[GLOBAL][Collaborative solutions] - Outlook Web (OWA)
Incident Report for Web Cloud
Resolved
Start time : 13/03/2024 00:00 UTC
End time : 14/05/2024 11:00 UTC
Root cause : Incident due to a software issue.
Our technical teams have implemented patches to resolve the problem. All impacted services are now operational.
Posted May 15, 2024 - 08:31 UTC
Update
To work around this issue, download the document, and then use the Microsoft Office desktop applications to view or edit it.
We are continuing to work on a fix for this issue.
Posted Apr 10, 2024 - 15:03 UTC
Update
We are continuing to work on a fix for this issue.
Posted Mar 25, 2024 - 10:14 UTC
Identified
Start time : 13/03/2024 00:00 UTC
Service impact : Following an mandatory update from Microsoft, adding templates to Exchange-based services and previewing Excel or Word documents is temporarily not functioning on OWA (Outlook on the web). Links for shared calendars is temporarily not functioning.
Root cause : Software issue
Ongoing actions : We are working with Microsoft to fix this issue.
Update will be post as significant progress is made.
Posted Mar 25, 2024 - 09:56 UTC
This incident affected: Collaborative solutions || EmailPro (Webmail), Collaborative solutions || MX Plan (Webmail), Collaborative solutions || Hosted Exchange (Webmail), and Collaborative solutions || Private Exchange (Webmail).