We are pleased to inform you that the incident affecting our Collaborative solutions offering has been resolved.
Start time : 11/12/2025 08:25 UTC End time : 11/12/2025 11:17 UTC Root Cause : The delay was due to a queueing issue that has now been resolved. No emails were lost during the incident.
We apologize for any inconvenience caused and appreciate your understanding.
Posted Dec 11, 2025 - 11:25 UTC
Identified
We are currently investigating an incident affecting our Collaborative solutions offering,.This is causing issues with mail reception and sending.
Here are some supplementary details :
Start time : 11/12/2025 08:25 UTC Impacted Service(s) : Some customers may currently be experiencing latency issues affecting their email service. Ongoing Actions : Our teams are investigating to determine the origin of the incident to fix it.
We will keep you updated on the progress and resolution.
We apologize for any inconvenience caused and appreciate your understanding.
Posted Dec 11, 2025 - 09:41 UTC
This incident affected: Collaborative solutions || Hosted Exchange (Mail Flow).