The scheduled maintenance has been completed. All services are operational since 13/11/2024 20:54 UTC
Posted Nov 13, 2024 - 20:56 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 13, 2024 - 20:00 UTC
Scheduled
As part of our continuous improvement plan, maintenance is scheduled on our MX Plan offer.
This may temporarily affect availability.
Start time : 13/11/2024 20:00 UTC End time : 13/11/2024 22:00 UTC Service impact : During this maintenance operation, emails will not be accessible for around 5 minutes. Service improvement : As part of our continuous improvement policy for the MX Plan product, we will be performing software maintenance.
Thank you for your understanding.
Posted Nov 13, 2024 - 15:37 UTC
This scheduled maintenance affected: Collaborative solutions || MX Plan (Mailbox Access).