OVHcloud Web Hosting Status

Current status
Legend
  • Operational
  • Degraded performance
  • Partial Outage
  • Major Outage
  • Under maintenance

[GRA][Web Hosting] - Cluster121 incident notification

Incident Report for Web Cloud

Update

We have new information regarding the incident that affected your service(s).

Please find below an update on the situation:
Update : The cluster121 was temporarily unavailable from 26/06/2026 17:00 UTC to 26/2026 18:00 UTC.
Ongoing Actions : Our teams are investigating the cause of the incident and working to resolve the latency issues experienced by customers.

We will keep you updated on the progress and resolution.

We apologize for any inconvenience caused and appreciate your understanding.
Posted Jun 26, 2026 - 18:13 UTC

Investigating

We are currently investigating an incident affecting our Web Hosting offering, which is causing temporary latency issue in the GRA region.

Here are some supplementary details :

Start time : 26/06/2026 09:12 UTC
Impacted Service(s) : Cluster121 is experiencing latency.
Customers Impact : Customers are currently experiencing slowdowns when attempting to perform operations on Cluster121.
Ongoing Actions : Our teams are investigating to determine the origin of the incident and fix it.

We will keep you updated on the progress and resolution.

We apologize for any inconvenience caused and appreciate your understanding.
Posted Jun 26, 2026 - 09:41 UTC
This incident affects: Web Hosting || Datacenter GRA (Cluster121).