We are pleased to inform you that the incident affecting our Web Hosting offering on Cluster100 has been resolved.
Start time : 17/07/2026 01:24 UTC. End time : 17/07/2026 03:15 UTC Root Cause : A service disruption occurred due to an unexpected underlying infrastructure malfunction.
We apologize for any inconvenience caused and appreciate your understanding.
Posted Jul 17, 2026 - 08:58 UTC
Monitoring
We had an incident on our our Web Hosting offering and service has been fully restored since 17/07/2026 03:15 UTC. Monitoring remains active to ensure long-term stability.
Here are some supplementary details :
Start time : 17/07/2026 01:24 UTC. Impacted Service(s) : The Cluster100 was experiencing latency. Customers Impact : Customers were temporarily facing slowness when trying to access and use their websites located in Cluster100. Root Cause : A service disruption occurred due to an unexpected underlying infrastructure malfunction.
We apologize for any inconvenience caused and appreciate your understanding.
Posted Jul 17, 2026 - 03:49 UTC
This incident affected: Web Hosting || Datacenter GRA (Cluster100).