We would like to inform you that the incident on our Mx Plan offering in EU has now been resolved.
Here is detail for this incident : Start time : 24/04/2025 07:00 UTC End time : 24/04/2025 12:02 UTC Root Cause : This incident was caused by a software issue.
We thank you for your understanding and patience throughout this incident.
Posted Apr 24, 2025 - 12:43 UTC
Investigating
We are currently experiencing an incident affecting our Mx Plan offering in EU.
Here is detail for this incident : Start time : 24/04/2025 07:00 UTC Impacted Service(s) : Access to mailboxes is temporarily unavailable. Customers Impact : Some customers may not be able to have access to their mailboxes. Ongoing Actions : Our teams are investigating to determine the origin of the incident to fix it.
We will keep you updated on the progress and resolution. We apologize for any inconvenience caused and appreciate your understanding.
Posted Apr 24, 2025 - 11:21 UTC
This incident affected: Collaborative solutions || MX Plan (Mailbox Access).