The scheduled maintenance has been completed. All services are operational. There has been no impact since 09/12/2024 16:33 UTC.
Posted Dec 09, 2024 - 16:36 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 04, 2024 - 09:00 UTC
Scheduled
As part of our continuous improvement plan, maintenance is scheduled on our mail offers.
Start time : 04/12/2024 09:00 UTC End time : 10/12/2024 10:05 UTC Service impact : None Service improvement : As part of our continuous improvement policy, we will be doing a maintenance on our mail offers.
Thank you for your understanding.
Posted Dec 03, 2024 - 16:21 UTC
This scheduled maintenance affected: Collaborative solutions || MX Plan (Reception, Delivery email, Webmail, Delivery).