We would like to inform you that the maintenance on our is now completed. All services are operational.
Thank you for your patience throughout this maintenance.
Posted Nov 27, 2025 - 01:07 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 26, 2025 - 21:30 UTC
Scheduled
As part of our continuous improvement plan, maintenance is scheduled on our Web Hosting offer on Filerz47 .
This may temporarily affect availability. Start time: 26/11/2025 21:30 UTC End time: 27/11/2025 04:00 UTC Service impact: Filerz47 will be temporarily unavailable for 30 minutes during the maintenance. Service improvement: We are going to migrate the filerz47 to keep our infrastructure up-to-date and more stable to avoid further downtime. The filerz will have a downtime of 30min during the migration.
Thank you for your understanding.
Posted Nov 26, 2025 - 17:44 UTC
This scheduled maintenance affected: Collaborative solutions || MX Plan (Reception, Delivery email, Mailbox Access, Redirection, Webmail, Delivery).