The scheduled maintenance has been completed. All services are operational since 05/02/2025 20:39 UTC.
Posted Feb 05, 2025 - 20:50 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 05, 2025 - 20:00 UTC
Scheduled
As part of our continuous improvement plan, maintenance is scheduled on our MX Plan offer.
Start time : 05/02/2025 2000 UTC End time : 05/02/2025 21:00 UTC Service impact : None . Service improvement : As part of our continuous improvement policy of our MX Plan product, we will be doing a maintenance on multiple network equipment.
Thank you for your understanding.
Posted Feb 05, 2025 - 16:03 UTC
This scheduled maintenance affected: Collaborative solutions || MX Plan (Mailbox Access).