OVHCloud Web Hosting Status

Current status
Legend
  • Operational
  • Degraded performance
  • Partial Outage
  • Major Outage
  • Under maintenance
ex.mail.ovh.net unreachable
Incident Report for Web Cloud
Resolved
Hello,

ex.mail.ovh.net is currently unreachable.
We are working on it.

Regards,

Update(s):

Date: 2021-05-20 08:12:44 UTC
ex.mail.ovh.net is now up.
Issue was related to a upgrade network component.
Posted May 20, 2021 - 07:33 UTC
This incident affected: Collaborative solutions || Hosted Exchange (Mailbox Access).