OVHcloud Web Hosting Status

Current status
Legend
  • Operational
  • Degraded performance
  • Partial Outage
  • Major Outage
  • Under maintenance

[GLOBAL][Collaborative solutions] - MXPlan incident notification

Incident Report for Web Cloud

Update

We have new information regarding the event that affected your service(s).

Please find below an update on the situation:
Update : During the migration, the emails sent or received will be stored and delivered once the operation has been completed.
Root Cause : This event is caused by this maintenance : https://web-cloud.status-ovhcloud.com/incidents/yczrbvxf8p36
Ongoing Actions : Our teams are mobilised to restore service as quickly as possible.

We will keep you updated on the progress and resolution.

We apologize for any inconvenience caused and appreciate your understanding.
Posted Mar 16, 2026 - 17:03 UTC

Identified

We are currently experiencing an ongoing incident. We have determined the origin of the issue affecting our Collaborative solutions offer.

Here are some supplementary details :

Start time : 16/03/2026 15:02 UTC
Impacted Service(s) : Access to mailboxes and webmail is unavailable.
Customers Impact : Customers are currently unable to access their mailboxes, which means they cannot read, send, or manage their emails.
Ongoing Actions : The incident has been identified and our teams are mobilised to restore service as quickly as possible.

We will keep you updated on the progress and resolution.

We apologize for any inconvenience caused and appreciate your understanding.
Posted Mar 16, 2026 - 15:51 UTC
This incident affects: Collaborative solutions || MX Plan (Mailbox Access, Webmail).