Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 20, 2024 - 22:30 UTC
Scheduled
Start time : 20/02/2024 22:30 UTC End time : 21/02/2024 00:30 UTC Service impact : Filerz1592 will be unavailable for 60 minutes during the maintenance Service improvement : We are going to migrate Filerz1592 to keep our infrastructure up-to-date
Posted Feb 08, 2024 - 22:20 UTC
This scheduled maintenance affected: Web Hosting || Datacenter GRA (Cluster031).