We are pleased to inform you that the incident affecting our Collaborative solutions offering, which was causing temporary availability issue in the GRA region has been resolved.
Start time : 26/11/2025 10:45 UTC End time : 26/11/2025 14:53 UTC Root Cause : This incident was caused by a network equipment and software issues.
We apologize for any inconvenience caused and appreciate your understanding.
Posted Nov 26, 2025 - 16:39 UTC
Monitoring
Service has been fully restored since 26/11/2025 14:53 UTC. Monitoring remains active to ensure long-term stability.
Here are some supplementary details :
Start time : 26/11/2025 10:45 UTC Impacted Service(s) : The MX Plan service was temporarily unavailable on Filerz 47. Customers Impact : Customers were temporarily unable to access webmail via the web interface or desktop client. Emails sent or received were temporarily unavailable and have been delivered once the incident was resolved.
We apologize for any inconvenience caused and appreciate your understanding.
Posted Nov 26, 2025 - 15:04 UTC
Update
Please find below an update on the situation: Update : The incident has been resolved by our teams, and no emails have been lost. Incoming/outgoing emails in the queue are currently being processed. However, due to the large number of emails, processing may take some time. Ongoing Actions : Our teams are currently processing the backlog.
We will get back to you when the situation is resolved.
We apologize for any inconvenience caused and appreciate your understanding.
Posted Nov 26, 2025 - 14:59 UTC
Identified
We have new information regarding the incident that affected your service(s).
Please find below an update on the situation: Update : This incident is caused by a hardware issue. Ongoing Actions : The incident has been identified and our teams are mobilised to restore service as quickly as possible.
We will keep you updated on the progress and resolution.
We apologize for any inconvenience caused and appreciate your understanding.
Posted Nov 26, 2025 - 12:32 UTC
Investigating
We are currently investigating an incident affecting our Collaborative solutions offering, which is causing temporary availability issue in the GRA region.
Here are some supplementary details :
Start time : 26/11/2025 10:45 UTC Impacted Service(s) : The MX Plan service is temporarily unavailable on Filerz 47. Customers Impact : Customers are temporarily unable to access webmail via the web interface or desktop client. Emails sent or received are temporarily unavailable and will be delivered once the incident is resolved. Ongoing Actions : Our teams are investigating to determine the origin of the incident to fix it.
We will keep you updated on the progress and resolution.
We apologize for any inconvenience caused and appreciate your understanding.
Posted Nov 26, 2025 - 11:18 UTC
This incident affected: Collaborative solutions || MX Plan (Reception, Delivery email, Mailbox Access, Redirection, Webmail, Delivery).