We are pleased to inform you that the incident affecting our Domains has been resolved.
Start time : 12/08/2025 06:12 UTC End time : 14/08/2025 07:20 UTC
We apologize for any inconvenience caused and appreciate your understanding.
Posted Aug 14, 2025 - 08:05 UTC
Identified
We are currently experiencing an ongoing incident. We have determined the origin of the issue affecting our our Domain Name .MS globally.
Here are some supplementary details :
Start time : 12/08/2025 06:12 UTC Impacted Service(s) : Multiple operations (Registration, Renew, Transfer, Restore, Delete) are temporarily unavailable for .MS domains. Customers Impact : Customers are temporarily unable to perform multiple operations (Registration, Renew, Transfer, Restore, Delete). Please note that websites are still available. Root Cause : This incident is caused by a maintenance of one of our provider. Ongoing Actions : The incident has been identified and our teams are mobilised to restore service as quickly as possible.
We will keep you updated on the progress and resolution.
We apologize for any inconvenience caused and appreciate your understanding.
Posted Aug 12, 2025 - 15:18 UTC
Investigating
We are currently experiencing an incident affecting our Domain Name .MS globally.
Here is detail for this incident : Start time : 12/08/2025 06:12 UTC Impacted Service(s) : Multiple operations (Registration, Renew, Transfer, Restore, Delete) are temporarily unavailable for .MS domains. Customers Impact : Customers are temporarily unable to perform multiple operations (Registration, Renew, Transfer, Restore, Delete). Please note that websites are still available. Ongoing Actions : Our teams are investigating to determine the origin of the incident to fix it.
Our teams are fully engaged and working to resolve the issue as quickly as possible. We will keep you updated on the progress and resolution. We apologize for any inconvenience caused and appreciate your understanding.
Posted Aug 12, 2025 - 09:06 UTC
This incident affected: Domains || Domains Name (Registration, Renew, Transfer, Restore, Delete).