We would like to inform you that the maintenance on our is now completed.
Thank you for your patience throughout this maintenance.
Posted Oct 17, 2025 - 01:07 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 16, 2025 - 20:30 UTC
Scheduled
As part of our continuous improvement plan, maintenance is scheduled on our Web Hosting offer on Filerz34.
This may temporarily affect availability. Start time: 16/10/2025 20:30 UTC End time: 16/10/2025 23:00 UTC Service impact: Filerz34 will be temporarily unavailable for 30 minutes during the maintenance. Service improvement: As part of our continuous improvement policy and to enhance the reliability of our infrastructure, we will be doing a maintenance on our Web Hosting offer for Filerz34.
Thank you for your understanding.
Posted Oct 14, 2025 - 20:46 UTC
This scheduled maintenance affected: Web Hosting || Datacenter GRA (Cluster021).