Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 24, 2024 - 20:00 UTC
Scheduled
As part of our continuous improvement plan, maintenance is scheduled on our MX Plan offer.
Start time : 24/09/2024 20:00 UTC End time : 24/09/2024 21:00 UTC Service impact : During this maintenance operation, emails will not be accessible for around 10 minutes. Service improvement : As part of our continuous improvement policy of our MX Plan product, we will be doing a maintenance on multiple network equipment.
Thank you for your understanding.
Posted Sep 23, 2024 - 20:20 UTC
This scheduled maintenance affected: Collaborative solutions || MX Plan (Mailbox Access).