Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 22, 2024 - 23:45 UTC
Scheduled
Start time : 22/02/2024 23:45 UTC End time : 23/02/2024 01:45 UTC Service impact : Filerz1626 will be unavailable for 60 minutes during the maintenance Service improvement : We are going to migrate Filerz1626 to keep our infrastructure up-to-date
Posted Feb 09, 2024 - 00:58 UTC
This scheduled maintenance affected: Web Hosting || Datacenter GRA (Cluster029).