OVHcloud Web Hosting Status

Current status
Legend
  • Operational
  • Degraded performance
  • Partial Outage
  • Major Outage
  • Under maintenance
FS#17665 — Hosted Exchange issue with login
Incident Report for Web Cloud
Resolved
We are experiencing some problems with our hosted exchange platform.
You may have problems logging in to the mailbox.

The Exchange team

Update(s):

Date: 2016-04-21 10:56:25 UTC
Inbox connection has returned. We are still experiencing slow connection times to OWA.

We are investigating the problem.

The Exchange team
Posted Apr 21, 2016 - 09:50 UTC