Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 20, 2023 - 21:00 UTC
Scheduled
Start time : 20/09/2023 21:00 UTC End time : 20/09/2023 22:00 UTC Service impact : The filerz will have a downtime of 30min during the migration. Service improvement : We are going to migrate the filerz26 (mail server) due to a hardware issue.
Posted Sep 20, 2023 - 16:55 UTC
This scheduled maintenance affected: Collaborative solutions || EmailPro (Reception, Delivery email, Mailbox Access, Redirection, Webmail, Delivery) and Collaborative solutions || MX Plan (Reception, Delivery email, Mailbox Access, Redirection, Webmail, Delivery).