Start time : 27/05/2023 16:25 UTC End Time : 27/05/2023 18:10 UTC Root cause : Network issue Our technical teams resolved the issue. All impacted services are now operational.
Posted May 27, 2023 - 18:14 UTC
Identified
Start time : 27/05/2023 16:25 UTC Service impact : MX plan services are unavailable on Filerz966 - Filerz1025 - Filerz955 - Filerz952 - Filerz1047. Root cause : Network issue. Related Incident :Incident link Ongoing actions : Our technical teams are investigating on this issue. Update will be post as significant progress is made.
Posted May 27, 2023 - 17:28 UTC
This incident affected: Collaborative solutions || MX Plan (Mailbox Access).