We had an incident on our CDN offer which has now been resolved.
Here are some supplementary details :
Start time : 21/11/2025 14:00 UTC End time : 21/11/2025 15:00 UTC Impacted Service(s) : The Content Delivery Network (CDN) was temporarily facing latencies. Customers Impact : Customers were temporarily facing latencies while trying to load their web pages. Root Cause : This incident was caused by a network issue.
We thank you for your understanding and patience throughout this incident.
Posted Nov 21, 2025 - 15:10 UTC
Investigating
We are currently experiencing an event affecting our CDN offer.
Start time : 21/11/2025 14:00 UTC
Our teams are fully committed to investigating this issue and working towards a resolution as soon as possible. As investigations are ongoing, we will share any new findings or updates with you as soon as possible.
We apologize for any inconvenience caused and appreciate your understanding.
Posted Nov 21, 2025 - 14:57 UTC
This incident affected: CDN || CDN Hosting (RBX, SBG, BHS).