Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 02, 2026 - 07:35 UTC
Scheduled
As part of our continuous improvement plan, maintenance is scheduled on our Web Hosting offer.
Start time : 02/06/2026 06:44 UTC End time : 02/06/2026 11:44 UTC Service impact : During this maintenance window, a network maintenance will be performed. Websites will be temporarily inaccessible during this time.
Thank you for your understanding.
Posted Jun 02, 2026 - 07:34 UTC
This scheduled maintenance affected: Web Hosting || Datacenter GRA (Cluster110).