The scheduled maintenance has been completed. All the services are now operational.
Posted Apr 01, 2025 - 22:26 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 01, 2025 - 18:00 UTC
Scheduled
As part of our continuous improvement plan, maintenance is scheduled on our Hosted and Private Exchange offers.
Start time : 01/04/2025 18:00 UTC End time : 01/04/2025 21:00 UTC Service impact : None Service improvement : As part of our continuous improvement policy, we will be doing a maintenance on our Hosted and Private Exchange offers by disabling TLS 1.0 and TLS 1.1. The deprecation of TLS 1.0 and 1.1, as well as the removal of the aforementioned cipher suites, will be implemented as follows: • TLS 1.0 and 1.1 will no longer be supported on our infrastructure, and any attempts to connect using these protocols will result in a connection error. • The removed cipher suites will be replaced with the updated alternatives, which will be used for all new connections. • We recommend that all users ensure their clients and applications are configured to use TLS 1.2, and support the updated cipher suites.
Thank you for your understanding.
Posted Apr 01, 2025 - 08:56 UTC
This scheduled maintenance affected: Collaborative solutions || Hosted Exchange (Mailbox Access) and Collaborative solutions || Private Exchange (Mailbox Access).