Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 11, 2026 - 19:20 UTC
Scheduled
As part of our continuous improvement plan, maintenance is scheduled on our Collaborative solutions offer.
Start time : 11/08/2026 18:00 UTC End time : 12/08/2026 17:00 UTC Service impact : Microsoft services may be unavailable during this maintenance. Service improvement : As part of our ongoing commitment to improvement, we will be carrying out maintenance on Microsoft services.
Thank you for your understanding.
Posted Aug 11, 2026 - 19:17 UTC
This scheduled maintenance affects: Collaborative solutions || MX Plan (Mailbox Access, Mail Flow, Operations).