We would like to inform you that the incident on our MX plan service on Filerz14. has now been resolved.
Here is detail for this incident : Start time : 21/04/2025 19:21 UTC End time : 21/04/2025 22:23 UTC Root Cause : This incident was caused by a malfunction on a hardware.
We thank you for your understanding and patience throughout this incident.
Posted Apr 21, 2025 - 22:33 UTC
Update
The incident is still ongoing. We would like to assure you that we are doing our utmost to resolve this situation as quickly as possible.
As soon as the situation evolves or the incident is resolved, we will keep you informed.
Thank you for your understanding
Posted Apr 21, 2025 - 21:59 UTC
Identified
We have new information regarding the incident that affected your service(s).
Please find below an update on the situation: Update : Our technical team has identified the cause of the incident and is currently working on resolving it. Ongoing Actions : The incident has been identified and our teams are mobilised to restore service as quickly as possible.
We will keep you updated on the progress and resolution. We apologize for any inconvenience caused and appreciate your understanding.
Posted Apr 21, 2025 - 20:21 UTC
Update
We are currently experiencing an incident affecting our Web Hosting offering, which is causing temporary Availability issues in the MX plan service on Filerz14.
Here is detail for this incident : Start time : 21/04/2025 19:21 UTC Impacted Service(s) : The MX Plan service is temporarily unavailable on Filerz14. Customers Impact : Customers are currently unable to access their mailboxes on filerz14. Ongoing Actions : Our teams are investigating to determine the origin of the incident to fix it.
We will keep you updated on the progress and resolution. We apologize for any inconvenience caused and appreciate your understanding.
Posted Apr 21, 2025 - 20:02 UTC
Investigating
We are currently experiencing an event affecting our Web hosting offer.
Our teams are fully committed to investigating this issue and working towards a resolution as soon as possible. As investigations are ongoing, we will share any new findings or updates with you as soon as possible.
We apologize for any inconvenience caused and appreciate your understanding.
Posted Apr 21, 2025 - 19:56 UTC
This incident affected: Collaborative solutions || MX Plan (Reception, Delivery email, Mailbox Access, Redirection, Webmail, Delivery).