Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 08, 2023 - 21:01 UTC
Scheduled
Start time : 08/06/2023 21:00 UTC End time : 08/06/2023 22:00 UTC Service impact : 30 minutes of downtime per filerz Service improvement : As part of our continuous improvement policy, we are migrating the filerz890 (webhosting server) to keep our infrastructure up-to-date.
Posted May 31, 2023 - 21:06 UTC
This scheduled maintenance affected: Web Hosting || Datacenter GRA (Cluster003).