We will keep you updated on the progress and resolution. We apologize for any inconvenience caused and appreciate your understanding.
Posted Jul 06, 2026 - 08:46 UTC
Update
Please find below an update on the situation: Update : We still have several Filerz emails impacted by this incident. Ongoing Actions : The incident has been identified and our teams are mobilised to restore service as quickly as possible.
We will keep you updated on the progress and resolution. We apologize for any inconvenience caused and appreciate your understanding.
Posted Jul 06, 2026 - 08:07 UTC
Identified
We are currently experiencing an ongoing incident. We have determined the origin of the issue affecting our Collaborative solutions offer.
Here are some supplementary details :
Start time : 06/07/2026 06:00 UTC Impacted Service(s) : Access to mailboxes and mail services is temporarily unavailable. Customers Impact : Some Customers are currently unable to log in to their email accounts via webmail or email clients. They are unable to send or receive emails. Emails received during the incident are being queued and will be delivered once the service is restored. Root Cause : This incident is caused by these maintenance activities : https://network.status-ovhcloud.com/incidents/1y3cdv1hm03g and https://network.status-ovhcloud.com/incidents/tsby2rmn5ftb Ongoing Actions : The incident has been identified and our teams are mobilised to restore service as quickly as possible.
We will keep you updated on the progress and resolution. We apologize for any inconvenience caused and appreciate your understanding.
Posted Jul 06, 2026 - 06:49 UTC
This incident affected: Collaborative solutions || MX Plan (Mailbox Access, Mail Flow).