Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 08, 2025 - 20:01 UTC
Scheduled
As part of our continuous improvement plan, we will be carrying out a maintenance on our Roundcube offer.
This may temporarily affect availability.
Start time : 08/10/2025 20:00 UTC End time : 08/10/2025 21:00 UTC Service impact : Roundcube will be unavailable for approximately 2 minutes during this maintenance window. Service improvement : As part of our continuous improvement policy, we will be doing a maintenance on our Collaborative solutions offer.
Thank you for your understanding.
Posted Sep 25, 2025 - 14:59 UTC
This scheduled maintenance affected: Collaborative solutions || MX Plan (Webmail).