Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 19, 2024 - 21:30 UTC
Scheduled
Start time : 19/02/2024 21:30 UTC End time : 19/02/2024 23:00 UTC Service impact : Filerz954 will be unavailable for 40 minutes during the maintenance Service improvement : We are going to migrate Filerz954 to keep our infrastructure up-to-date
Posted Feb 08, 2024 - 21:15 UTC
This scheduled maintenance affected: Web Hosting || Datacenter GRA (Cluster028).