Start time : 31/01/2024 10:05 UTC End time : 31/01/2024 12:35 UTC Root cause : Webmail access unavailable Our technical teams resolved the issue. All impacted services are now operational.
Posted Jan 31, 2024 - 12:56 UTC
Identified
Start time : 31/01/2024 10:05 UTC Service impact : Webmail access unavailable Root cause : Network Issue. Ongoing actions : Our technical teams are fixing the issue. Update will be post as significant progress is made.
Posted Jan 31, 2024 - 12:40 UTC
Investigating
Start time : 31/01/2024 10:05 UTC Service impact : Webmail access unavailable Ongoing actions : Investigating Our technical teams are working on the issue. Update will be post as significant progress is made.
Posted Jan 31, 2024 - 10:42 UTC
This incident affected: Collaborative solutions || MX Plan (Webmail).