We are pleased to inform you that the incident affecting our Collaborative solutions offering has been resolved.
Start time : 16/06/2026 10:10 UTC End time : 19/06/2026 16:00 UTC Root Cause : A service disruption occurred due to an unexpected underlying infrastructure malfunction.
We apologize for any inconvenience caused and appreciate your understanding.
Posted Jun 25, 2026 - 13:27 UTC
Update
We are continuing to investigate this issue.
Posted Jun 25, 2026 - 12:32 UTC
Investigating
We are currently investigating an incident affecting our Collaborative solutions offering, which is causing temporary issue. Here are some supplementary details :
Start time : 16/06/2026 10:10 UTC Impacted Service(s) : Email delivery and redirection may be delayed or rejected.
We will keep you updated on the progress and resolution.
We apologize for any inconvenience caused and appreciate your understanding.