OVHcloud Web Hosting Status

Current status
Legend
  • Operational
  • Degraded performance
  • Partial Outage
  • Major Outage
  • Under maintenance
[Global][Web Cloud] - Hosted Exchange incident notification
Incident Report for Web Cloud
Resolved
This incident has been resolved.
Start time : 16/02/2024 16:59 UTC
End time : 23/02/2024 10:21 UTC
Posted Feb 23, 2024 - 10:21 UTC
Monitoring
Dear Customer,

The Microsoft Outlook product is facing an issue that could generate an authentication process for some accounts. This issue is related to an additional security feature called Extended Protection that was enabled after the last security update to mitigate the vulnerability described in CVE-2024-21410.

Microsoft's current recommendation in this case is to add a registry key as described at https://learn.microsoft.com/en-us/exchange/plan-and-deploy/post-installation-tasks/security-best-practices/exchange-extended-protection?view=exchserver-2019#ntlm-version-requirements.

We hope that this will help you to resolve the issue if you are affected.
Posted Feb 21, 2024 - 11:08 UTC
Update
The fix did not produce the expected results, customers are recommended to update Outlook client to the latest version or to apply a registry key to use the correct NTLM protocol : NTLM version requirements.
Our teams are continuing to work on a fix.
Posted Feb 20, 2024 - 18:28 UTC
Update
Our technical teams will implement a fix during the night.
An update will be posted as soon as significant progress is made.
Posted Feb 19, 2024 - 16:22 UTC
Update
Our teams have identified the source of the connection problem. There are two workarounds:
- The first workaround is to update your Outlook client to the latest version.
- The second workaround is to apply a registry key to use the correct NTLM protocol : NTLM version requirements

Our technical teams are continuing to work on this issue.
An update will be issued as soon as significant progress is made.
Posted Feb 19, 2024 - 15:30 UTC
Update
Our technical teams are continuing to work on this issue.
An update will be issued as soon as significant progress is made.
Posted Feb 19, 2024 - 13:06 UTC
Update
We are continuing to work on a fix for this issue.
Posted Feb 19, 2024 - 10:59 UTC
Identified
Start time : 16/02/2024 16:59 UTC
Service impact : Customers may face problems with connexion, only outlook is concerned.
Root cause : Following a fix implemented to resolve this incident https://web-cloud.status-ovhcloud.com/incidents/7vfj2lp3jdkd, some customers may experience connection problems for outlook accounts.
Ongoing actions : A fix in progress.
Posted Feb 19, 2024 - 09:34 UTC
This incident affected: Collaborative solutions || Hosted Exchange (Mailbox Access).